arp tell 0.0.0.0

Chuck Hemker (n2por@amsat.org)
Fri, 17 Dec 1999 03:05:58 -0500 (EST)


I ran across this the other day, and I'm not sure if it is a bug or a feature
but I figured I should mention it just in case.

My ISP was playing with their DHCP server and while pump was trying to get an
address I was doing a tcpdump and noticed a bunch of arp requests going out
saying looking for x.x.x.x tell 0.0.0.0. I believe this was because there was
a default route pointing to the interface but the interface didn't have an IP
address yet. I was just wondering if that might just confuse the other end if
someone tried to reply.

My machine:
Redhat 6.0
Kernel 2.2.11 with patch (from 2.2.12) for problem of forgetting to keep send
queue full (one second ping delay problem)
Pump 0.7.0-1 (from Redhat errata) with extra debugging code for a different
problem
2 network cards
one to external cable modem
one to local network
no NAT or IPchains

I should be able to duplicate this on a more standard system if needed. Just
let me know.
(Just use pump (or maybe dhcpcd) on an interface that doesn't have a DHCP
server from a machine that doesn't have a default route pointing somewhere else)

I just figured I should mention this. Let me know if you need any help. (or
if this really is a bug, maybe I could try to track it down)

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu