use XON/XOFF w/pppd?

Raymond Blum (raytrace@interport.net)
Wed, 22 Dec 1999 23:04:55 -0500


Hi
I have a machine that has been running ppp to provide IP Masquerading
for my little network. All was going well until recently when chat
stopped getting responses from the modem. The CD and TR lights came on
as expected, the RD and SD lights flash as I send commands to the modem,
but no responses were received by chat.

minicom could not talk to the modem either. I have two serial ports,
same on each. I checked the modem out on another machine and it seems
fine. Other devices, specifically my palmpilot cradle, worked on both
ports.

I then found that if I set hardware flow control to none and used
XON/XOFF I could talk to the modem just fine. I used stty to make sure
that /dev/modem was configured for RTS/CTS. It was.

So... I figured that something has happened to my UART or some other
component of my on-motherboard serial ports. I wanted to try to get pppd
to use XON/XOFF, using the following options:
nocrtscts xonxoff asyncmap 20A0000 escape FF

No effect. I also then used stty to set rtscts off and ixon ixoff on.
Still no change.

Am I missing something needed in the pppd options? Or does anyone else
have any insight into my serial port problem?

Thanks
---Raymond
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu