Re: [PATCH] scripts/misc-check: update export checks for EXPORT_SYMBOL_FOR_MODULES()
From: Nicolas Schier
Date: Mon Aug 25 2025 - 11:39:40 EST
On Mon, Aug 25, 2025 at 05:00:37PM +0200, Vlastimil Babka wrote:
> The module export checks are looking for EXPORT_SYMBOL_GPL_FOR_MODULES()
> which was renamed to EXPORT_SYMBOL_FOR_MODULES(). Update the checks.
>
> Fixes: 6d3c3ca4c77e ("module: Rename EXPORT_SYMBOL_GPL_FOR_MODULES to EXPORT_SYMBOL_FOR_MODULES")
> Signed-off-by: Vlastimil Babka <vbabka@xxxxxxx>
> ---
> I've missed these new checks when renaming the export macro due to my
> git grep being too narrow. My commit went through Christian's vfs tree
> but seems the script is part of kbuild (which is currently Odd fixes).
> ---
> scripts/misc-check | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
Good catch, thanks a lot! We will gladly take the patch to kbuild-next.
Reviewed-by: Nicolas Schier <nsc@xxxxxxxxxx>