Re: [PATCH v2 1/7] ACPI: CPPC: add perf control read API and clarify naming
From: Rafael J. Wysocki
Date: Mon Aug 25 2025 - 14:34:23 EST
On Sat, Aug 23, 2025 at 10:02 PM Sumit Gupta <sumitg@xxxxxxxxxx> wrote:
>
> Add cppc_get_perf_ctrls() to read performance control register values.
> Rename existing APIs for clarity as:
> - To distinguish between:
> - Feedback counters (fb_ctrs): Read-only performance monitoring data.
> - Performance controls (perf_ctrls): Read-write config registers.
> - cppc_set_epp_perf() updates both EPP and Autonomous Selection.
>
> API's renamed:
> - cppc_set_perf() to cppc_set_perf_ctrls().
> - cppc_get_perf_ctrs() to cppc_get_perf_fb_ctrs().
> - cppc_get_perf_ctrs_sample() to cppc_get_perf_fb_ctrs_sample().
> - cppc_set_epp_perf() to cppc_set_epp_and_autosel().
> Remove redundant energy_perf field from 'struct cppc_perf_caps' since
> the same information is available in 'struct cppc_perf_ctrls' which is
> actively used.
>
> All existing callers are updated to maintain compatibility.
First, this is too much in one patch IMV and second, I honestly don't
see a reason for the renames above.
This generally makes tracking the code changes history harder.
Thanks!