Re: (subset) [PATCH 0/6] scsi: use min()/min_t()/max() to improve code

From: Martin K. Petersen
Date: Mon Aug 25 2025 - 22:35:39 EST


On Fri, 15 Aug 2025 20:16:02 +0800, Qianfeng Rong wrote:

> Use min()/min_t()/max() to reduce the code and improve readability.
>
> No functional changes.
>
> Qianfeng Rong (6):
> scsi: bfa: use min_t() to improve code
> scsi: hpsa: use min()/min_t() to improve code
> scsi: lpfc: use min() to improve code
> scsi: megaraid_sas: use max() to improve code
> scsi: mpi3mr: use min() to improve codee
> scsi: qla2xxx: use min() to improve code
>
> [...]

Applied to 6.18/scsi-queue, thanks!

[2/6] scsi: hpsa: use min()/min_t() to improve code
https://git.kernel.org/mkp/scsi/c/0138c16872bd
[3/6] scsi: lpfc: use min() to improve code
https://git.kernel.org/mkp/scsi/c/e79aa10e288c

--
Martin K. Petersen