Re: [PATCH v9 05/18] x86/apic: Add update_vector() callback for apic drivers

From: Upadhyay, Neeraj
Date: Tue Aug 26 2025 - 00:07:21 EST




On 8/25/2025 8:19 PM, Borislav Petkov wrote:
On Wed, Aug 20, 2025 at 09:06:52AM +0530, Upadhyay, Neeraj wrote:
+static void apic_chipd_update_vector(struct irq_data *irqd, unsigned int newvec,

What is "chipd" supposed to denote?

chip data (struct apic_chip_data)

So this function should be called chip_data_update() or so?


or chip_data_update_vector() as the updates are specific for a new vector assignment?

It is static so it doesn't need the "apic_" prefix and "chipd" doesn't make
a whole lotta of sense so let's call it as what it does.


Got it. However, I see other static functions in this file using "apic_" prefix (in some cases, maybe to differentiate "apic_chip_data" from a generic "chip_data" in common kernel/irq/ subys?).


- Neeraj