Re: [PATCH v11 22/24] mm: zswap: Allocate pool batching resources if the compressor supports batching.
From: Barry Song
Date: Tue Aug 26 2025 - 00:42:35 EST
On Tue, Aug 26, 2025 at 12:27 PM Sridhar, Kanchana P
<kanchana.p.sridhar@xxxxxxxxx> wrote:
>
>
>
> > -----Original Message-----
> > From: Barry Song <21cnbao@xxxxxxxxx>
> > Sent: Monday, August 25, 2025 8:48 PM
> > To: Sridhar, Kanchana P <kanchana.p.sridhar@xxxxxxxxx>
> > Cc: linux-kernel@xxxxxxxxxxxxxxx; linux-mm@xxxxxxxxx;
> > hannes@xxxxxxxxxxx; yosry.ahmed@xxxxxxxxx; nphamcs@xxxxxxxxx;
> > chengming.zhou@xxxxxxxxx; usamaarif642@xxxxxxxxx;
> > ryan.roberts@xxxxxxx; ying.huang@xxxxxxxxxxxxxxxxx; akpm@linux-
> > foundation.org; senozhatsky@xxxxxxxxxxxx; linux-crypto@xxxxxxxxxxxxxxx;
> > herbert@xxxxxxxxxxxxxxxxxxx; davem@xxxxxxxxxxxxx;
> > clabbe@xxxxxxxxxxxx; ardb@xxxxxxxxxx; ebiggers@xxxxxxxxxx;
> > surenb@xxxxxxxxxx; Accardi, Kristen C <kristen.c.accardi@xxxxxxxxx>;
> > Gomes, Vinicius <vinicius.gomes@xxxxxxxxx>; Feghali, Wajdi K
> > <wajdi.k.feghali@xxxxxxxxx>; Gopal, Vinodh <vinodh.gopal@xxxxxxxxx>
> > Subject: Re: [PATCH v11 22/24] mm: zswap: Allocate pool batching resources
> > if the compressor supports batching.
> >
> > Hi Kanchana,
> >
> >
> > [...]
> > >
> > > + /*
> > > + * Set the unit of compress batching for large folios, for quick
> > > + * retrieval in the zswap_compress() fast path:
> > > + * If the compressor is sequential (@pool->compr_batch_size is 1),
> > > + * large folios will be compressed in batches of
> > ZSWAP_MAX_BATCH_SIZE
> > > + * pages, where each page in the batch is compressed sequentially.
> > > + * We see better performance by processing the folio in batches of
> > > + * ZSWAP_MAX_BATCH_SIZE, due to cache locality of working set
> > > + * structures.
> > > + */
> > > + pool->batch_size = (pool->compr_batch_size > 1) ?
> > > + pool->compr_batch_size : ZSWAP_MAX_BATCH_SIZE;
> > > +
> > > zswap_pool_debug("created", pool);
> > >
> > > return pool;
> > >
> >
> > It’s hard to follow — you add batch_size and compr_batch_size in this
> > patch, but only use them in another. Could we merge the related changes
> > into one patch instead of splitting them into several that don’t work
> > independently?
>
> Hi Barry,
>
> Thanks for reviewing the code and for your comments! Sure, I can merge
> this patch with the next one. I was trying to keep the changes modularized
> to a) zswap_cpu_comp_prepare(), b) zswap_store() and c) zswap_compress()
> so the changes are broken into smaller parts, but I can see how this can
> make the changes appear disjointed.
>
> One thing though: the commit logs for each of the patches will
> also probably need to be merged, since I have tried to explain the
> changes in detail.
It’s fine to merge the changelog and present the story as a whole. Do we
really need both pool->batch_size and pool->compr_batch_size? I assume
pool->batch_size = pool->compr_batch_size if HW supports batch; otherwise
pool->compr_batch_size = 1. It seems pool->compr_batch_size should either
be a bool or be dropped. If we drop it, you can still check whether HW
supports batch via crypto_acomp_batch_size() when doing compression:
if (crypto_acomp_batch_size() > 1)
compress in steps of PAGE_SIZE;
else
compress in steps of batch_size;
no ?
Thanks
Barry