Re: [PATCH v7 0/8] sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask()

From: Shrikanth Hegde
Date: Tue Aug 26 2025 - 06:06:31 EST




On 8/26/25 9:43 AM, K Prateek Nayak wrote:
This version uses Peter's suggestion from [1] as if and incrementally
adds cleanup on top to the arch/ bits. I've tested the x86 side but the
PowerPC and the s390 bits are only build tested. Review and feedback is
greatly appreciated.

[1] https://lore.kernel.org/lkml/20250825091910.GT3245006@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/

Patches are prepared on top of tip:master at commit 4628e5bbca91 ("Merge
branch into tip/master: 'x86/tdx'")
---
changelog v6..v7:

o Fix the s390 and ppc build errors (Intel test robot)

o Use Peter's diff as is and incrementally do the cleanup on top. The
PowerPC part was slightly more extensive due to the lack of
CONFIG_SCHED_MC in arch/powerpc/Kconfig.

v6: https://lore.kernel.org/lkml/20250825120244.11093-1-kprateek.nayak@xxxxxxx/
---
K Prateek Nayak (7):
powerpc/smp: Rename cpu_corgroup_* to cpu_corgrp_*
powerpc/smp: Export cpu_coregroup_mask()
powerpc/smp: Introduce CONFIG_SCHED_MC to guard MC scheduling bits
sched/topology: Unify tl_smt_mask() across core and all arch
sched/topology: Unify tl_cls_mask() across core and x86
sched/topology: Unify tl_mc_mask() across core and all arch
sched/topology: Unify tl_pkg_mask() across core and all arch

Peter Zijlstra (1):
sched/fair: Get rid of sched_domains_curr_level hack for tl->cpumask()

Can the names be standardized to begin with tl_ ?

arch/powerpc/kernel/smp.c: SDTL_INIT(smallcore_smt_mask, powerpc_smt_flags, SMT);
arch/powerpc/kernel/smp.c: SDTL_INIT(shared_cache_mask, powerpc_shared_cache_flags, CACHE);
arch/s390/kernel/topology.c: SDTL_INIT(cpu_book_mask, NULL, BOOK),
arch/s390/kernel/topology.c: SDTL_INIT(cpu_drawer_mask, NULL, DRAWER),
kernel/sched/topology.c: tl[i++] = SDTL_INIT(sd_numa_mask, NULL, NODE);
kernel/sched/topology.c: tl[i] = SDTL_INIT(sd_numa_mask, cpu_numa_flags, NUMA);