Re: [PATCH 1/4] staging: media: atomisp: Remove unnecessary forward declarations

From: Andy Shevchenko
Date: Tue Aug 26 2025 - 11:09:30 EST


On Tue, Aug 26, 2025 at 10:44:11AM +0000, Adrian Barnaś wrote:
> Get rid of fifo_monitor_status_valid() and fifo_monitor_status_accept()
> forward declaration because it brings no value.

If you send more than one patch, get used to cover letter.
My script [1] does this for me, so I won't forget doing it.
Also one may use `b4 relay`.

[1]: https://github.com/andy-shev/home-bin-tools/blob/master/ge2maintainer.sh

The patch series (all patches) LGTM,
Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxx>

...

> + return (data >> (((port_id * 2) + _hive_str_mon_valid_offset))) & 0x1;

Side note, perhaps change this (in a separate followup) to

return data & BIT(port_id * 2 + _hive_str_mon_valid_offset);

It will significantly increase readability.

...

> + return (data >> (((port_id * 2) + _hive_str_mon_accept_offset))) & 0x1;

In the same way

return data & BIT(port_id * 2 + _hive_str_mon_accept_offset);

--
With Best Regards,
Andy Shevchenko