Re: [PATCH] net: hns3: use kcalloc() instead of kzalloc()
From: patchwork-bot+netdevbpf
Date: Tue Aug 26 2025 - 20:20:36 EST
Hello:
This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@xxxxxxxxxx>:
On Mon, 25 Aug 2025 22:27:52 +0800 you wrote:
> As noted in the kernel documentation [1], open-coded multiplication in
> allocator arguments is discouraged because it can lead to integer overflow.
>
> Use devm_kcalloc() to gain built-in overflow protection, making memory
> allocation safer when calculating allocation size compared to explicit
> multiplication.
>
> [...]
Here is the summary with links:
- net: hns3: use kcalloc() instead of kzalloc()
https://git.kernel.org/netdev/net-next/c/7e484a97f6d5
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html