Re: [PATCH net-next v2] netfilter: nft_payload: Use csum_replace4() instead of opencoding

From: Simon Horman
Date: Wed Aug 27 2025 - 08:42:33 EST


On Mon, Aug 18, 2025 at 11:48:30AM +0200, Christophe Leroy wrote:
> Open coded calculation can be avoided and replaced by the
> equivalent csum_replace4() in nft_csum_replace().
>
> Signed-off-by: Christophe Leroy <christophe.leroy@xxxxxxxxxx>

Reviewed-by: Simon Horman <horms@xxxxxxxxxx>