Re: [PATCH] drivers: perf: use us_to_ktime() where appropriate

From: Robin Murphy
Date: Wed Aug 27 2025 - 10:06:22 EST


On 27/08/2025 10:36 am, Mark Rutland wrote:
[adding Robin and LAKML]

On Wed, Aug 13, 2025 at 04:32:57PM +0800, Xichao Zhao wrote:
The arm_ccn_pmu_poll_period_us are more suitable for using
the us_to_ktime(). This can make the code more concise and
enhance readability.

Signed-off-by: Xichao Zhao <zhao.xichao@xxxxxxxx>

Superficially this looks fine to me, so:

Acked-by: Mark Rutland <mark.rutland@xxxxxxx>

Will, I assume that (if no-one complains) you'll pick this up when
queueing PMU patches.

Yup, the new helper looks entirely appropriate here. We could perhaps take this opportunity to drop the unnecessary cast as well though, since automatic promotion from unsigned int to u64 is perfectly well-defined and unsurprising.

Thanks,
Robin.


Mark.

---
drivers/perf/arm-ccn.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/perf/arm-ccn.c b/drivers/perf/arm-ccn.c
index 1a0d0e1a2263..8af3563fdf60 100644
--- a/drivers/perf/arm-ccn.c
+++ b/drivers/perf/arm-ccn.c
@@ -565,7 +565,7 @@ module_param_named(pmu_poll_period_us, arm_ccn_pmu_poll_period_us, uint,
static ktime_t arm_ccn_pmu_timer_period(void)
{
- return ns_to_ktime((u64)arm_ccn_pmu_poll_period_us * 1000);
+ return us_to_ktime((u64)arm_ccn_pmu_poll_period_us);
}
--
2.34.1