RE: [EXT] Re: [PATCH v9 2/6] arm64: dts: freescale: rename imx93.dtsi to imx91_93_common.dtsi and modify them

From: Joy Zou
Date: Wed Aug 27 2025 - 21:52:05 EST


Hi Alexande,
> -----Original Message-----
> From: Alexander Stein <alexander.stein@xxxxxxxxxxxxxxx>
> Sent: 2025年8月27日 16:33
> To: robh@xxxxxxxxxx; krzk+dt@xxxxxxxxxx; conor+dt@xxxxxxxxxx;
> shawnguo@xxxxxxxxxx; s.hauer@xxxxxxxxxxxxxx; kernel@xxxxxxxxxxxxxx;
> festevam@xxxxxxxxx; richardcochran@xxxxxxxxx; andrew+netdev@xxxxxxx;
> davem@xxxxxxxxxxxxx; edumazet@xxxxxxxxxx; kuba@xxxxxxxxxx;
> pabeni@xxxxxxxxxx; mcoquelin.stm32@xxxxxxxxx;
> alexandre.torgue@xxxxxxxxxxx; frieder.schrempf@xxxxxxxxxx;
> primoz.fiser@xxxxxxxxx; othacehe@xxxxxxx;
> Markus.Niebel@xxxxxxxxxxxxxxx; Joy Zou <joy.zou@xxxxxxx>
> Cc: devicetree@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx;
> imx@xxxxxxxxxxxxxxx; linux-arm-kernel@xxxxxxxxxxxxxxxxxxx;
> linux@xxxxxxxxxxxxxxx; netdev@xxxxxxxxxxxxxxx; linux-pm@xxxxxxxxxxxxxxx;
> linux-stm32@xxxxxxxxxxxxxxxxxxxxxxxxxxxx; Frank Li <frank.li@xxxxxxx>
> Subject: [EXT] Re: [PATCH v9 2/6] arm64: dts: freescale: rename imx93.dtsi to
> imx91_93_common.dtsi and modify them
>
> Caution: This is an external email. Please take care when clicking links or
> opening attachments. When in doubt, report the message using the 'Report
> this email' button
>
>
> Hi,
>
> Am Montag, 25. August 2025, 11:12:19 CEST schrieb Joy Zou:
> > The design of i.MX91 platform is very similar to i.MX93 and only
> > some small differences.
> >
> > If the imx91.dtsi include the imx93.dtsi, each add to imx93.dtsi
> > requires an remove in imx91.dtsi for this unique to i.MX93, e.g. NPU.
> > The i.MX91 isn't the i.MX93 subset, if the imx93.dtsi include the
> > imx91.dtsi, the same problem will occur.
> >
> > Common + delta is better than common - delta, so add
> imx91_93_common.dtsi
> > for i.MX91 and i.MX93, then the imx93.dtsi and imx91.dtsi will include the
> > imx91_93_common.dtsi.
> >
> > Rename imx93.dtsi to imx91_93_common.dtsi and move i.MX93 specific
> > part from imx91_93_common.dtsi to imx93.dtsi.
> >
> > Reviewed-by: Frank Li <Frank.Li@xxxxxxx>
> > Signed-off-by: Joy Zou <joy.zou@xxxxxxx>
> > ---
> > Changes for v7:
> > 1.The aliases are removed from common.dtsi because the imx93.dtsi aliases
> > are removed.
> >
> > Changes for v6:
> > 1. merge rename imx93.dtsi to imx91_93_common.dtsi and move i.MX93
> > specific part from imx91_93_common.dtsi to imx93.dtsi patch.
> > 2. restore copyright time and add modification time.
> > 3. remove unused map0 label in imx91_93_common.dtsi.
> > ---
> > .../{imx93.dtsi => imx91_93_common.dtsi} | 140 +-
> > arch/arm64/boot/dts/freescale/imx93.dtsi | 1484 ++---------------
> > 2 files changed, 163 insertions(+), 1461 deletions(-)
> > copy arch/arm64/boot/dts/freescale/{imx93.dtsi =>
> imx91_93_common.dtsi} (91%)
> > rewrite arch/arm64/boot/dts/freescale/imx93.dtsi (97%)
>
> It's not shown in the diff, but can you add a 'soc' phandle for 'soc@0' node?
> So it can be referenced by imx91 or imx93 individually.
Add it when needed to reduce difference and facilitate review.
BR
Joy Zou
>
> Best regards
> Alexander
>