Re: [RFC PATCH 04/12] KVM: x86/mmu: Rename kvm_tdp_map_page() to kvm_tdp_prefault_page()

From: Sean Christopherson
Date: Thu Aug 28 2025 - 14:51:06 EST


On Thu, Aug 28, 2025, Rick P Edgecombe wrote:
> On Tue, 2025-08-26 at 17:05 -0700, Sean Christopherson wrote:
> > Rename kvm_tdp_map_page() to kvm_tdp_prefault_page() now that it's used
> > only by kvm_arch_vcpu_pre_fault_memory().
> >
> > No functional change intended.
>
> I realize you are just trying to do map->prefault here, but "page" seems
> redundant once you have "prefault" in the name. Why page here vs all the other
> fault handler functions without it?

kvm_tdp_prefault() feels a bit ambiguous/bare. Many of the fault helpers do have
"page", it's just before the fault part.

kvm_mmu_finish_page_fault
kvm_handle_page_fault
kvm_tdp_page_fault
direct_page_fault
nonpaging_page_fault
kvm_tdp_mmu_page_fault

(and probably more)

How about kvm_tdp_page_prefault()? Or kvm_tdp_do_prefault(), but I think I like
kvm_tdp_page_prefault() a little more.