Re: [PATCH net-next v10 2/2] net: af_packet: Use hrtimer to do the retire operation
From: Xin Zhao
Date: Sun Aug 31 2025 - 22:28:37 EST
On Sun, 2025-08-31 at 21:21 -0400, Willem wrote:
> > - p1->retire_blk_tov = prb_calc_retire_blk_tmo(po,
> > - req_u->req3.tp_block_size);
> > - p1->tov_in_jiffies = msecs_to_jiffies(p1->retire_blk_tov);
> > + p1->interval_ktime = ms_to_ktime(prb_calc_retire_blk_tmo(po,
> > + req_u->req3.tp_block_size));
>
> req_u is not aligned with the line above.
I have some questions regarding the alignment here. According to the alignment requirements,
req_u should be aligned below the po variable. However, if it is aligned below po, the line
will become very long, which may affect readability. In this special case, can I align it to
prb_calc_retire_blk_tmo instead, or should I continue to align it to the po variable?
What should I do next?
Should I change the alignment, and resend PATCH with the reviewed information of version 10?
Thanks
Xin Zhao