Re: [PATCH] platform/x86: quickstart: Use devm_mutex_init()

From: Ilpo Järvinen
Date: Mon Sep 08 2025 - 06:20:38 EST


On Sun, 07 Sep 2025 15:32:26 +0200, Christophe JAILLET wrote:

> Use devm_mutex_init() instead of hand-writing it.
>
> This saves some LoC, improves readability and saves some space in the
> generated .o file.
>
> Before:
> ======
> text data bss dec hex filename
> 7607 2616 64 10287 282f drivers/platform/x86/quickstart.o
>
> [...]


Thank you for your contribution, it has been applied to my local
review-ilpo-next branch. Note it will show up in the public
platform-drivers-x86/review-ilpo-next branch only once I've pushed my
local branch there, which might take a while.

The list of commits applied:
[1/1] platform/x86: quickstart: Use devm_mutex_init()
commit: c4f8b11bacd562f38c85f4f81a0a4426b267df70

--
i.