Re: [PATCH] rust: pin-init: add references to previously initialized fields

From: Boqun Feng

Date: Mon Sep 08 2025 - 15:38:26 EST


On Mon, Sep 08, 2025 at 10:57:36AM +0200, Danilo Krummrich wrote:
> On Mon Sep 8, 2025 at 10:27 AM CEST, Benno Lossin wrote:
> > On Mon Sep 8, 2025 at 4:08 AM CEST, Boqun Feng wrote:
> >> On Mon, Sep 08, 2025 at 01:33:26AM +0200, Danilo Krummrich wrote:
> >>> On Mon Sep 8, 2025 at 12:51 AM CEST, Benno Lossin wrote:
> >>> > I actually came up with a third option that looks best IMO:
> >>> >
> >>> > init!(MyStruct {
> >>> > x: 42,
> >>> > #[with_binding]
> >>> > y: 24,
> >>> > z: *y,
> >>> > })
> >>> >
> >>> > The `#[with_binding]` attribute makes the macro generate a variable `y`.
> >>> > `x` & `z` don't give access to their value. (we of course should come up
> >>> > with a better name).
> >>> >
> >>> > Any thoughts?
> >>>
> >>> It may be a bit verbose is some cases, but it makes things pretty obvious, so
> >>> LGTM.
> >>>
> >>> How about just #[bind] or #[access]?
> >
> > I like `#[bind]`.
> >
> >> #[shadow] or #[maybe_rebind] ? Or #[pin_ref], the last one is clear
> >> about the purpose.
> >
> > Hmm in `init!` it's never pinned.
>
> I thought about #[shadow] as well, but it is not really accurate I think, as we
> might not shadow anything. #[maybe_rebind] sounds a bit like it conditionally
> rebinds, as in "it may not do anything", but it always binds.
>
> So, I think it should one clear instruction, i.e. #[bind], #[access], #[ref],
> #[use], #[let], etc.

In that sense I think `#[let]` is best? Because it indicates this field
initialization works as a `let`-statement (in term of creating a new
binding), of course I don't have strong ojections against other options.

Regards,
Boqun