Re: [PATCH v5 15/19] kasan: x86: Apply multishot to the inline report handler

From: Maciej Wieczor-Retman
Date: Tue Sep 09 2025 - 04:43:00 EST


On 2025-09-08 at 22:19:11 +0200, Andrey Konovalov wrote:
>On Mon, Sep 8, 2025 at 3:04 PM Maciej Wieczor-Retman
><maciej.wieczor-retman@xxxxxxxxx> wrote:
>>
>> >> + if (kasan_multi_shot_enabled())
>> >> + return true;
>> >
>> >It's odd this this is required on x86 but not on arm64, see my comment
>> >on the patch that adds kasan_inline_handler().
>> >
>>
>> I think this is needed if we want to keep the kasan_inline_recover below.
>> Because without this patch, kasan_report() will report a mismatch, an then die()
>> will be called. So the multishot gets ignored.
>
>But die() should be called only when recovery is disabled. And
>recovery should always be enabled.

Hmm I thought when I was testing inline mode last time, that recovery was always
disabled. I'll recheck later.

But just looking at llvm code, hwasan-recover has init(false). And the kernel
doesn't do anything to this value in Makefile.kasan. Perhaps it just needs to be
corrected in the Makefile.kasan?

>But maybe this is the problem with when kasan_inline_handler(), see my
>comment on the the patch #13.

--
Kind regards
Maciej Wieczór-Retman