Re: [External] : [PATCH] ocfs2: retire ocfs2_drop_inode() and I_WILL_FREE usage
From: Mateusz Guzik
Date: Tue Sep 09 2025 - 05:57:58 EST
On Tue, Sep 9, 2025 at 11:51 AM Jan Kara <jack@xxxxxxx> wrote:
>
> On Mon 08-09-25 17:39:22, Mateusz Guzik wrote:
> > I think generic_delete_inode is a really bad name for what the routine
> > is doing and it perhaps contributes to the confusion in the thread.
> >
> > Perhaps it could be renamed to inode_op_stub_always_drop or similar? I
> > don't for specifics, apart from explicitly stating that the return
> > value is to drop and bonus points for a prefix showing this is an
> > inode thing.
>
> I think inode_always_drop() would be fine...
sgtm. unfortunately there are quite a few consumers, so I don't know
if this is worth the churn and consequently I'm not going for it.
But should you feel inclined... ;-)
--
Mateusz Guzik <mjguzik gmail.com>