Re: (subset) [PATCH] leds: is31fl319x: Use devm_mutex_init()
From: Lee Jones
Date: Thu Sep 11 2025 - 11:23:45 EST
On Sun, 07 Sep 2025 12:16:09 +0200, Christophe JAILLET wrote:
> Use devm_mutex_init() instead of hand-writing it.
>
> This saves some LoC, improves readability and saves some space in the
> generated .o file.
>
> Before:
> ======
> text data bss dec hex filename
> 20011 6752 128 26891 690b drivers/leds/leds-is31fl319x.o
>
> [...]
Applied, thanks!
[1/1] leds: is31fl319x: Use devm_mutex_init()
commit: 96e048fa11d6aedf4add4c2f93a8d06445948056
--
Lee Jones [李琼斯]