Re: [PATCH v2 06/15] mm, swap: rename and move some swap cluster definition and helpers
From: Baolin Wang
Date: Sun Sep 07 2025 - 23:04:08 EST
On 2025/9/6 03:13, Kairui Song wrote:
From: Kairui Song <kasong@xxxxxxxxxxx>
No feature change, move cluster related definitions and helpers to
mm/swap.h, also tidy up and add a "swap_" prefix for cluster lock/unlock
helpers, so they can be used outside of swap files. And while at it, add
kerneldoc.
Signed-off-by: Kairui Song <kasong@xxxxxxxxxxx>
Acked-by: Chris Li <chrisl@xxxxxxxxxx>
Reviewed-by: Barry Song <baohua@xxxxxxxxxx>
Acked-by: David Hildenbrand <david@xxxxxxxxxx>
---
LGTM.
Reviewed-by: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx>