Re: [PATCH v2 5/9] panic: use panic_try_start() in vpanic()

From: Petr Mladek

Date: Tue Sep 16 2025 - 07:20:30 EST


On Mon 2025-08-25 10:29:33, Jinchao Wang wrote:
> vpanic() had open-coded logic to claim panic_cpu with atomic_try_cmpxchg.
> This is already handled by panic_try_start().
>
> Switch to panic_try_start() and use panic_on_other_cpu() for the fallback
> path.
>
> This removes duplicate code and makes panic handling consistent across
> functions.
>
> --- a/kernel/panic.c
> +++ b/kernel/panic.c
> @@ -415,7 +415,6 @@ void vpanic(const char *fmt, va_list args)
> static char buf[1024];
> long i, i_next = 0, len;
> int state = 0;
> - int old_cpu, this_cpu;
> bool _crash_kexec_post_notifiers = crash_kexec_post_notifiers;
>
> if (panic_on_warn) {
> @@ -452,13 +451,10 @@ void vpanic(const char *fmt, va_list args)
> * `old_cpu == this_cpu' means we came from nmi_panic() which sets
> * panic_cpu to this CPU. In this case, this is also the 1st CPU.
> */

The above comment does not fit any longer. I think that it can
be removed, maybe except for the 1st paragraph.

> - old_cpu = PANIC_CPU_INVALID;
> - this_cpu = raw_smp_processor_id();
> -
> /* atomic_try_cmpxchg updates old_cpu on failure */

Also this comment should be removed.

> - if (atomic_try_cmpxchg(&panic_cpu, &old_cpu, this_cpu)) {
> + if (panic_try_start()) {
> /* go ahead */
> - } else if (old_cpu != this_cpu)
> + } else if (panic_on_other_cpu())
> panic_smp_self_stop();
>
> console_verbose();

Otherwise, it looks good. And the comments might be removed
by a followup patch.

Best Regards,
Petr