Re: [PATCH v2 7/9] panic/printk: replace this_cpu_in_panic() with panic_on_this_cpu()

From: Petr Mladek
Date: Tue Sep 16 2025 - 07:23:06 EST


On Mon 2025-08-25 10:29:35, Jinchao Wang wrote:
> The helper this_cpu_in_panic() duplicated logic already provided by
> panic_on_this_cpu().
>
> Remove this_cpu_in_panic() and switch all users to panic_on_this_cpu().
>
> This simplifies the code and avoids having two helpers for the same check.
>
> Signed-off-by: Jinchao Wang <wangjinchao600@xxxxxxxxx>

It is great that the helper functions were consolidated and moved
from printk to panic code.

Reviewed-by: Petr Mladek <pmladek@xxxxxxxx>

Best Regards,
Petr