Re: [PATCH v2 8/9] panic/printk: replace other_cpu_in_panic() with panic_on_other_cpu()
From: Petr Mladek
Date: Tue Sep 16 2025 - 07:24:05 EST
On Mon 2025-08-25 10:29:36, Jinchao Wang wrote:
> The helper other_cpu_in_panic() duplicated logic already provided by
> panic_on_other_cpu().
>
> Remove other_cpu_in_panic() and update all users to call
> panic_on_other_cpu() instead.
>
> This removes redundant code and makes panic handling consistent.
>
> Signed-off-by: Jinchao Wang <wangjinchao600@xxxxxxxxx>
Looks good:
Reviewed-by: Petr Mladek <pmladek@xxxxxxxx>
Best Regards,
Petr