Re: [RFC PATCH 01/12] mm/cma: add tunable for CMA fallback limit

From: Rik van Riel
Date: Tue Sep 16 2025 - 16:24:23 EST


On Mon, 2025-09-15 at 19:51 +0000, Frank van der Linden wrote:
>
> +#ifdef CONFIG_CMA
> + {
> + .procname = "cma_first_limit",
> + .data = &cma_first_limit,
> + .maxlen = sizeof(cma_first_limit),
> + .mode = 0644,
> + .proc_handler = proc_dointvec_minmax,
> + .extra1 = SYSCTL_ZERO,
> + .extra2 = SYSCTL_ONE_HUNDRED,
> + },
> +#endif
>  };
>
I like the code, but the name is a little confusing.

Maybe something like "prefer_cma_percent"?

--
All Rights Reversed.