Re: [PATCH v3 03/11] cxl/region: Rename misleading variable name @hpa to @range

From: Robert Richter
Date: Wed Sep 17 2025 - 04:11:20 EST


On 15.09.25 11:25:55, Jonathan Cameron wrote:
> On Mon, 15 Sep 2025 09:27:36 +0200
> Robert Richter <rrichter@xxxxxxx> wrote:
>
> > On 12.09.25 10:33:30, Dave Jiang wrote:
> > >
> > >
> > > On 9/12/25 7:45 AM, Robert Richter wrote:
> > > > @hpa is actually a @range, rename variables accordingly.
> > >
> > > it's a range of HPA right? May as well call it 'hpa_range' to distinguish from 'dpa_range' or 'spa_range'
> >
> > To me this is ok as it is locally used only in the functions. I used
> > the short version to not hit the 80 char line limit in some of the
> > statements for readability. Range is most of the time HPA unless for
> > special cases, which use a prefix then. It also becomes clear viewed
> > in context, e.g.
> >
> > range = &cxld->hpa_range;
> >
> > Thus, I rather would like to not change that.
>
> I'm with Dave on this one. Better to have some slightly long lines
> and avoid any potential confusion.

Ok, thanks.

-Robert