Re: [PATCH v3 05/13] mm/vma: rename __mmap_prepare() function to avoid confusion
From: Pedro Falcato
Date: Wed Sep 17 2025 - 06:49:38 EST
On Tue, Sep 16, 2025 at 03:11:51PM +0100, Lorenzo Stoakes wrote:
> Now we have the f_op->mmap_prepare() hook, having a static function called
> __mmap_prepare() that has nothing to do with it is confusing, so rename
> the function to __mmap_setup().
>
> Signed-off-by: Lorenzo Stoakes <lorenzo.stoakes@xxxxxxxxxx>
> Reviewed-by: David Hildenbrand <david@xxxxxxxxxx>
I would love to bikeshed on the new name (maybe something more descriptive?),
but I don't really mind.
Reviewed-by: Pedro Falcato <pfalcato@xxxxxxx>
--
Pedro