Re: [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry
From: Steven Rostedt
Date: Tue Sep 23 2025 - 05:38:17 EST
On Tue, 23 Sep 2025 17:20:00 +0800
Menglong Dong <menglong8.dong@xxxxxxxxx> wrote:
> The fprobe_entry() is used by fgraph_ops, so rename it to
> fprobe_fgraph_entry to be more distinctive.
The change log should be more specific and state that this will allow
to have fprobes to use ftrace too. I didn't know why you did this until
I saw the second patch. As change logs should be self contain, it
should have enough information to not rely on knowing other commits to
understand why the patch is made.
-- Steve