Re: [PATCH RFC 5/7] i2c: davinci: calculate bus freq from Hz instead of kHz

From: Bartosz Golaszewski

Date: Mon Sep 22 2025 - 10:42:46 EST


On Mon, 22 Sep 2025 08:21:00 +0200, Marcus Folkesson
<marcus.folkesson@xxxxxxxxx> said:
> The bus frequency is unnecessarily converted between Hz and kHz in
> several places.
> This is probably an old legacy from the old times (pre-devicetrees)
> when the davinci_i2c_platform_data took the bus_freq in kHz.
>
> Stick to Hz.
>

This looks good but would you mind also changing the name of the field to
bus_freq_hz in order to leave zero change of misinterpreting it in the future?

Bartosz