Re: [PATCH 1/2] btrfs: Prevent open-coded arithmetic in kmalloc

From: Miquel Sabaté Solà

Date: Mon Sep 22 2025 - 08:47:26 EST


Hello,

David Sterba @ 2025-09-22 12:28 +02:

> On Fri, Sep 19, 2025 at 04:58:15PM +0200, Miquel Sabaté Solà wrote:
>> As pointed out in the documentation, calling 'kmalloc' with open-coded
>> arithmetic can lead to unfortunate overflows and this particular way of
>> using it has been deprecated. Instead, it's preferred to use
>> 'kmalloc_array' in cases where it might apply so an overflow check is
>> performed.
>
> So this is an API cleanup and it makes sense to use the checked
> multiplication but it should be also said that this is not fixing any
> overflow because in all cases the multipliers are bounded small numbers
> derived from number of items in leaves/nodes.

Yes, it's just an API cleanup and I don't think it fixes any current bug
in the code base. So no need to CC stable or anything like that.

>
>> Signed-off-by: Miquel Sabaté Solà <mssola@xxxxxxxxxx>
>
> Reviewed-by: David Sterba <dsterba@xxxxxxxx>

Thanks for the review!
Miquel

Attachment: signature.asc
Description: PGP signature