RE: [PATCH rtw-next] wifi: rtw89: Replace hardcoded strings with helper functions

From: Ping-Ke Shih

Date: Mon Sep 22 2025 - 01:50:55 EST


Yu-Chun Lin <eleanor15x@xxxxxxxxx> wrote:
> Replace hardcoded strings with 'str_on_off()', 'str_enable_disable()',
> and 'str_read_write()'.
>
> The change improves readability and enables potential string deduplication
> by the linker, which may slightly reduce binary size.

Have you measured the change of binary size? Maybe you can share the result
here.

>
> Signed-off-by: Yu-Chun Lin <eleanor15x@xxxxxxxxx>
> ---
> drivers/net/wireless/realtek/rtw89/rtw8851b_rfk.c | 10 ++++++----
> drivers/net/wireless/realtek/rtw89/rtw8852a_rfk.c | 10 ++++++----
> drivers/net/wireless/realtek/rtw89/rtw8852b_rfk.c | 8 +++++---
> drivers/net/wireless/realtek/rtw89/rtw8852c_rfk.c | 11 ++++++-----
> drivers/net/wireless/realtek/rtw89/usb.c | 3 ++-
> drivers/net/wireless/realtek/rtw89/wow.c | 5 ++++-
> 6 files changed, 29 insertions(+), 18 deletions(-)
>
> diff --git a/drivers/net/wireless/realtek/rtw89/rtw8851b_rfk.c
> b/drivers/net/wireless/realtek/rtw89/rtw8851b_rfk.c
> index 84c46d2f4d85..000753061e38 100644
> --- a/drivers/net/wireless/realtek/rtw89/rtw8851b_rfk.c
> +++ b/drivers/net/wireless/realtek/rtw89/rtw8851b_rfk.c
> @@ -2,6 +2,8 @@
> /* Copyright(c) 2022-2023 Realtek Corporation
> */
>
> +#include <linux/string_choices.h>
> +

Driver has included this implicitly, so don't need to include it across
whole patch.

Otherwise looks good to me.