Re: [PATCH 25/32] ns: add to_<type>_ns() to respective headers

From: Thomas Gleixner

Date: Sun Sep 21 2025 - 03:35:30 EST


On Wed, Sep 10 2025 at 16:37, Christian Brauner wrote:

> Every namespace type has a container_of(ns, <ns_type>, ns) static inline
> function that is currently not exposed in the header. So we have a bunch
> of places that open-code it via container_of(). Move it to the headers
> so we can use it directly.
>
> Signed-off-by: Christian Brauner <brauner@xxxxxxxxxx>

Acked-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>