[PATCH v2 0/5] drm/solomon: Code improvements and DRM helper adoption

From: Iker Pedrosa

Date: Sat Sep 20 2025 - 05:46:15 EST


This patch series improves the Solomon SSD130x DRM driver by adopting
existing DRM helpers, improving code clarity, and following kernel
coding standards.

* Patch #1 moves DRM GEM framebuffer CPU access calls to make critical
sections more visible and maintainable.
* Patch #2 replaces WARN_ON with drm_WARN_ON_ONCE to prevent log spam.
* Patch #3 adopts drm_crtc_helper_mode_valid_fixed() for mode
validation.
* Patch #4 adopts drm_connector_helper_get_modes_fixed() for mode
management.
* Patch #5 enforces one assignment per line per kernel coding style.

These improvements reduce code duplication by leveraging existing DRM
infrastructure and enhance code readability without changing
functionality.

Signed-off-by: Iker Pedrosa <ikerpedrosam@xxxxxxxxx>
---
Changes in v2:
- Use a goto label to ensure drm_dev_exit() is called in the error path
of drm_gem_fb_begin_cpu_access().
- Link to v1: https://lore.kernel.org/r/20250912-improve-ssd130x-v1-0-bc9389ed299e@xxxxxxxxx

---
Iker Pedrosa (5):
drm/solomon: Move calls to drm_gem_fb_end_cpu*()
drm/solomon: Use drm_WARN_ON_ONCE instead of WARN_ON
drm/solomon: Simplify mode_valid() using DRM helper
drm/solomon: Simplify get_modes() using DRM helper
drm/solomon: Enforce one assignment per line

drivers/gpu/drm/solomon/ssd130x.c | 80 ++++++++++++++++-----------------------
1 file changed, 32 insertions(+), 48 deletions(-)
---
base-commit: c571cb70e1ed43ee543c70151e61a001ab2eefa2
change-id: 20250912-improve-ssd130x-b45b89ff4693

Best regards,
--
Iker Pedrosa <ikerpedrosam@xxxxxxxxx>