Re: [PATCH net-next] rust: net::phy inline if expressions to improve read_status

From: Thorsten Blum

Date: Fri Sep 19 2025 - 09:32:09 EST


On 19. Sep 2025, at 14:54, Andrew Lunn wrote:
> On Fri, Sep 19, 2025 at 01:20:08PM +0200, Thorsten Blum wrote:
>> Inline the if expressions for dev.set_speed() and dev.set_duplex() to
>> improve read_status(). This ensures dev.set_speed() is called only once
>
> What is the issue of calling it twice, or 42 times??
>
>> and allows us to remove the local variable 'duplex'.
>
> And what is wrong with local variables?
>
> And did you disassemble the code? What is the compiler actually doing?
> Does it actually have a stack variable, or is it just a register? Does
> the optimiser end up with just a single call to set_speed()?
>
> This is slow path code. It gets called at most once per
> second. Performance does not matter. Which means readability has much
> higher preference. And i find the older version much easier to read.

There's obviously nothing wrong with local variables. This patch is not
about performance improvements, but writing consistent and idiomatic
Rust code.

Currently, dev.set_duplex() uses a local variable and is called once,
whereas dev.set_speed() doesn't use a local variable and is called
twice. This is just a cleanup patch using idiomatic (afaik) Rust code.

Thanks,
Thorsten