Re: [PATCH] usb: dwc3: Log dwc3 instance name in traces
From: Prashanth K
Date: Fri Sep 19 2025 - 06:59:46 EST
On 9/13/2025 3:24 AM, Thinh Nguyen wrote:
>>> You're right. I forgot that we can't do virt_to_phys() for ioremapped
>>> resource...
>>>
>>> In that case, can we pass the dwc3 structure in the dwc3_readl/writel? I
>>> know there are many places that this change may touch, but I feel that
>>> it's easier to read than creating the new macro dwc3_readl/writel.
>>>
>>> Thanks,
>>> Thinh
>>
>> 1) Passing dwc3 structure to dwc3_readl/writel will need changes in
>> around 250 places, we can do that using 'find and replace'.
>
> Yikes..
>
>>
>> 2) OR we can use container_of(base, struct dwc3, regs)) to get dwc pointer,
>> this will not work in few places where we use dep->regs (~6 places). we
>> can just create a separate function dwc3_dep_readl/writel for dep->regs,
>
> We can just update the endpoint macros to something like this:
> #define DWC3_DEPCMD(n) (DWC3_DEP_BASE(n) + 0x0c)
>
> so we can do this:
> dwc3_readl(dwc->regs, DWC3_DEPCMD(dep->number));
>
> We will get the proper endpoint offset, and we can also remove the dep->regs.
>
>> and get dwc3 from dep. This will have lesser number of changes, and less
>> impact on git history.
>>
>> I'm more inclined towards approach2, but fine with both approaches, let
>> me know which one suits here.
>>
>> We can use snprintf on res->start to get the HW addr and store that
>> string into dwc3. Is that fine?
>>
>
> Option 2 sounds good.
>
> Thanks!
> Thinh
I think we need to go ahead with approach 1 (Passing dwc3 structure to
dwc3_readl/writel), because we were wrong about the usage of
container_of(), it wouldn't work since it's a __iomem pointer.
I'm planning to break this into a 3 patch series
1. Removal of dep->regs and use dwc->regs everywhere
2. Use dwc pointer in all dwc3_readl/writel()
3. Adding the base addr in traces.
Regards,
Prashanth K