Re: [PATCH] completion: Use designated initializers for struct completion

From: Valentin Schneider

Date: Thu Sep 18 2025 - 10:47:44 EST


On 11/09/25 12:30, Thorsten Blum wrote:
> Switch COMPLETION_INITIALIZER to the more modern and flexible designated
> initializers. This improves readability and allows struct fields to be
> reordered. No functional changes intended.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxx>

Reviewed-by: Valentin Schneider <vschneid@xxxxxxxxxx>