Re: [PATCH v2 1/3] mm/migrate: rename page to folio leftovers
From: Zi Yan
Date: Wed Jul 01 2026 - 11:44:15 EST
On 1 Jul 2026, at 1:17, Shivank Garg wrote:
> Rename migrate_folio_undo_src()'s page_was_mapped parameter to was_mapped,
> unmap_and_move_huge_page() to unmap_and_move_hugetlb_folio(), its
> page_was_mapped variable to was_mapped and fix stale "page" wording in its
> comments.
>
> Also fix migrate_folio() kerneldoc to say "folio" instead of "page".
>
> Suggested-by: Dev Jain <dev.jain@xxxxxxx>
> Suggested-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>
> Signed-off-by: Shivank Garg <shivankg@xxxxxxx>
> ---
> mm/migrate.c | 36 +++++++++++++++++-------------------
> 1 file changed, 17 insertions(+), 19 deletions(-)
>
LGTM.
Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
Best Regards,
Yan, Zi