[PATCH 0/8] hrtimer: Untangle base definitions from hrtimer.h
From: Thomas Weißschuh (Schneider Electric)
Date: Thu Jul 02 2026 - 06:06:10 EST
Currently the hrtimer base structure definitions are included from the
widely used linux/hrtimer.h header.
Any change to the base structures will trigger a nearly full rebuild.
That inclusion is not really necessary as nearly no user needs the base
bits anyways.
Signed-off-by: Thomas Weißschuh (Schneider Electric) <thomas.weissschuh@xxxxxxxxxxxxx>
---
Thomas Weißschuh (Schneider Electric) (8):
hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h
hrtimer: Move hrtimer_callback_running() to hrtimer_bases.h
hrtimer: Move hrtimer_update_function() to hrtimer.c
tick: Explicitly include linux/hrtimer_bases.h
hrtimer: Explicitly include linux/hrtimer_bases.h
hrtimer: Explicitly include some necessary headers in hrtimer_rearm.h
x86/speculation: Explicitly include linux/types.h
hrtimer: Remove inclusion of hrtimer_bases.h remove from hrtimer.h
arch/x86/include/asm/nospec-branch.h | 1 +
include/linux/hrtimer.h | 34 ++---------------------
include/linux/{hrtimer_defs.h => hrtimer_bases.h} | 14 ++++++++--
include/linux/hrtimer_rearm.h | 5 ++++
kernel/sched/fair.c | 2 ++
kernel/time/hrtimer.c | 25 +++++++++++++++++
kernel/time/tick-internal.h | 1 +
sound/drivers/dummy.c | 1 +
8 files changed, 49 insertions(+), 34 deletions(-)
---
base-commit: dc59e4fea9d83f03bad6bddf3fa2e52491777482
change-id: 20260626-hrtimer-header-dependencies-5a7d2ddff43f
Best regards,
--
Thomas Weißschuh <thomas.weissschuh@xxxxxxxxxxxxx>