Re: [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot

From: Lance Yang

Date: Thu Jul 02 2026 - 08:31:26 EST



On Mon, Jun 29, 2026 at 08:25:30PM +0100, Lorenzo Stoakes wrote:
>Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer
>to a VMA is confusing.
>
>Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this
>confusion.
>
>No functional change intended.
>
>Signed-off-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
>---

straight rename, no stale callers that I can spot ;) Feel free to add:

Reviewed-by: Lance Yang <lance.yang@xxxxxxxxx>