[PATCH] wifi: ath9k: use max() for pulse duration selection

From: Chun-Cheng Chang

Date: Thu Jul 02 2026 - 09:34:39 EST


Use max() to select the larger primary or extension channel pulse
duration in ath9k_postprocess_radar_event().

This matches the RSSI selection just below and improves readability
without changing behavior.

Signed-off-by: Chun-Cheng Chang <frank0988855428@xxxxxxxxx>
---
drivers/net/wireless/ath/ath9k/dfs.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath9k/dfs.c b/drivers/net/wireless/ath/ath9k/dfs.c
index 2fb73a5e1d51..370346450675 100644
--- a/drivers/net/wireless/ath/ath9k/dfs.c
+++ b/drivers/net/wireless/ath/ath9k/dfs.c
@@ -239,10 +239,7 @@ ath9k_postprocess_radar_event(struct ath_softc *sc,
* Radiated testing, when pulse is on DC, different pri and
* ext durations are reported, so take the larger of the two
*/
- if (ard->pulse_length_ext >= ard->pulse_length_pri)
- dur = ard->pulse_length_ext;
- else
- dur = ard->pulse_length_pri;
+ dur = max(ard->pulse_length_ext, ard->pulse_length_pri);
DFS_STAT_INC(sc, dc_phy_errors);

/* when both are present use stronger one */
--
2.53.0