RE: [PATCH v2 20/31] x86/virt/tdx: Add a helper to loop on TDX_INTERRUPTED_RESUMABLE
From: Ackerley Tng
Date: Sat Jul 04 2026 - 10:45:35 EST
"Tian, Kevin" <kevin.tian@xxxxxxxxx> writes:
>> From: Xu Yilun <yilun.xu@xxxxxxxxxxxxxxx>
>> Sent: Saturday, March 28, 2026 12:01 AM
>>
>> +static u64 __maybe_unused __seamcall_ir_resched(sc_func_t sc_func, u64
How about __seamcall_retry_interrupted, to emphasize that this function
retries a certain kind of seamcall?
I think resched is part of the implementation, of what's done while
retrying, which might not need to be part of the name.
No strong opinion though. Thanks for considering.
>> fn,
>> + struct tdx_module_args *args)
>> +{
>
> 'ir' sounds redundant with the trailing 'resched'?
>
> not big deal, just a bit confusing when seeing it in IOMMU side where
> 'ir' also refers to 'interrupt remapping' and is frequently used in
> irq_remapping.c... :)