[PATCH] drm/exynos: vidi: use memdup_user() instead of kmalloc() and copy_from_user()
From: mdshahid03
Date: Sun Jul 05 2026 - 07:02:59 EST
From: Mohammad Shahid <mdshahid03@xxxxxxxxx>
Use memdup_user() to replace the open-coded kmalloc() and
copy_from_user() sequence.
This simplifies the code while preserving the existing behavior.
This issue was reported by memdup_user.cocci.
Signed-off-by: Mohammad Shahid <mdshahid03@xxxxxxxxx>
---
drivers/gpu/drm/exynos/exynos_drm_vidi.c | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/exynos/exynos_drm_vidi.c b/drivers/gpu/drm/exynos/exynos_drm_vidi.c
index 67bbf9b8bc0e..183671de711e 100644
--- a/drivers/gpu/drm/exynos/exynos_drm_vidi.c
+++ b/drivers/gpu/drm/exynos/exynos_drm_vidi.c
@@ -273,14 +273,9 @@ int vidi_connection_ioctl(struct drm_device *drm_dev, void *data,
size = (hdr.extensions + 1) * EDID_LENGTH;
- edid_buf = kmalloc(size, GFP_KERNEL);
- if (!edid_buf)
- return -ENOMEM;
-
- if (copy_from_user(edid_buf, edid_userptr, size)) {
- kfree(edid_buf);
- return -EFAULT;
- }
+ edid_buf = memdup_user(edid_userptr, size);
+ if (IS_ERR(edid_buf))
+ return PTR_ERR(edid_buf);
drm_edid = drm_edid_alloc(edid_buf, size);
kfree(edid_buf);
--
2.43.0