Re: [PATCH v2 6/6] mm: rename ARCH_ENABLE_THP_MIGRATION to ARCH_HAS_PMD_SOFTLEAVES
From: David Hildenbrand (Arm)
Date: Mon Jul 06 2026 - 14:32:38 EST
On 7/6/26 13:42, Usama Arif wrote:
> CONFIG_ARCH_ENABLE_THP_MIGRATION gates PMD-level migration entries.
> PMD-level device-private entries use the same migration mechanism and
> therefore require the same architecture support.
>
> Upcoming PMD-level swap entries can use the same PMD softleaf helpers
> without depending on page migration, so rename the architecture gate to
> CONFIG_ARCH_HAS_PMD_SOFTLEAVES. This describes the PMD entry capability
> rather than one current user of it.
>
> This is a pure rename: the set of selecting architectures (x86, arm64,
> s390, riscv, loongarch, and powerpc on PPC_BOOK3S_64) and the gating
> semantics are unchanged.
>
> No functional change intended.
>
> Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
> Signed-off-by: Usama Arif <usama.arif@xxxxxxxxx>
> ---
Acked-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>
--
Cheers,
David