Re: [PATCH v2 1/2] staging: sm750fb: rename setAllEngOff to set_all_eng_off

From: Greg KH

Date: Tue Jul 07 2026 - 05:10:12 EST


On Mon, May 25, 2026 at 02:15:37AM +0300, Michail Tatas wrote:
> Rename variable setAllEngOff to set_all_eng_off as
> per the Linux coding standards
>
> Signed-off-by: Michail Tatas <michail.tatas@xxxxxxxxx>
> ---
> drivers/staging/sm750fb/sm750.c | 2 +-
> drivers/staging/sm750fb/sm750.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
> index 89c811e0806c..00c293430a7d 100644
> --- a/drivers/staging/sm750fb/sm750.c
> +++ b/drivers/staging/sm750fb/sm750.c
> @@ -848,7 +848,7 @@ static void sm750fb_setup(struct sm750_dev *sm750_dev, char *src)
> sm750_dev->init_parm.mem_clk = 0;
> sm750_dev->init_parm.master_clk = 0;
> sm750_dev->init_parm.power_mode = 0;
> - sm750_dev->init_parm.setAllEngOff = 0;
> + sm750_dev->init_parm.set_all_eng_off = 0;
> sm750_dev->init_parm.reset_memory = 1;
>
> /* defaultly turn g_hwcursor on for both view */
> diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
> index d2c522e67f26..589ae51444f8 100644
> --- a/drivers/staging/sm750fb/sm750.h
> +++ b/drivers/staging/sm750fb/sm750.h
> @@ -44,7 +44,7 @@ struct init_status {
> ushort chip_clk;
> ushort mem_clk;
> ushort master_clk;
> - ushort setAllEngOff;
> + ushort set_all_eng_off;
> ushort reset_memory;
> };

If this is only set and never read, why is it needed at all?

thanks,

greg k-h