[RFC PATCH v1.2 3/7] mm/damon/core: s/accesses_bp_to_nr_accesses/sample_bp_to_count/
From: SJ Park
Date: Tue Jul 07 2026 - 21:34:04 EST
accesses_bp_to_nr_accesses() actually converts a positive samples ratio
to the count. Rename it to better describe what it really does and not
confusing for more general uses.
Signed-off-by: SJ Park <sj@xxxxxxxxxx>
---
mm/damon/core.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/mm/damon/core.c b/mm/damon/core.c
index 177e5abc981ef..dea63083917b0 100644
--- a/mm/damon/core.c
+++ b/mm/damon/core.c
@@ -876,11 +876,11 @@ static unsigned int damon_age_for_new_attrs(unsigned int age,
return age * old_attrs->aggr_interval / new_attrs->aggr_interval;
}
-/* convert access ratio in bp (per 10,000) to nr_accesses */
-static unsigned int damon_accesses_bp_to_nr_accesses(
- unsigned int accesses_bp, struct damon_attrs *attrs)
+/* convert sample ratio in bp (per 10,000) to count */
+static unsigned int damon_sample_bp_to_count(
+ unsigned int bp, struct damon_attrs *attrs)
{
- return accesses_bp * damon_nr_samples_per_aggr(attrs) / 10000;
+ return bp * damon_nr_samples_per_aggr(attrs) / 10000;
}
/* Convert nr_accesses to access ratio in bp (per 10,000) */
@@ -893,7 +893,7 @@ static unsigned int damon_nr_accesses_to_accesses_bp(
static unsigned int damon_nr_accesses_for_new_attrs(unsigned int nr_accesses,
struct damon_attrs *old_attrs, struct damon_attrs *new_attrs)
{
- return damon_accesses_bp_to_nr_accesses(
+ return damon_sample_bp_to_count(
damon_nr_accesses_to_accesses_bp(
nr_accesses, old_attrs),
new_attrs);
--
2.47.3