RE: [RFC PATCH v2 00/13] mm: rework anon_vma and remove anon_vma_chain
From: wangtao
Date: Tue Jul 07 2026 - 23:26:39 EST
> > At first, I thought I was the only one who found anon_vma hard to
> > understand. After reading your earlier email, I realized that many people
> also consider it difficult to follow.
>
> Right, that's how Lorenzo started his work, trying to replace/remove
> anon_vma entirely.
>
> So I tried a different approach and implemented
> > anon_vma rmap using a simpler doubly linked list plus depth mechanism.
>
> And this is what I don't understand. You were told that Lorenzo is working on
> removing anon_vma, yet you decided to work on + send something that
> reworks anon_vma?
>
> Also, I am really curious about your expectation: not having a single patch
> contributed to MM, even worse, not a single RB tag or anything, yet you
> rework one of the most complicated part of MM repeatedly using other
> complicated approaches, and immediately start demand technical discussions?
> After sending an absolute horrible v1?
>
> I really try to be a nice person, but really, am I dreaming?
>
It’s simple: optimize memory usage and share it with the community.
Wish you all the best.
>
> Obviously, Lorenzo is still working om his approach, about which there were
> discussions at conferences and LWN articles.
>
> Stating "that you waited for a while" is ludicrous given that your old patch set
> was posted around one month ago, and a complete redesign -- moving away
> from anon_vma -- is not expected to be a short-term thing.
>
> Meanwhile, Lorenzo is sending real cleanups [1] as preparation for bigger
> changes. ... which is what we usually expect on such fundamental reworks.
>
> I'm really left clueless here why we anyone should spend time trying to thing
> through yet another data structure and yet another locking scheme, for
> something we want to remove entirely?
>
> Again, I really try to be a nice person, but something here just doesn't add up.
>
> [1] https://lore.kernel.org/r/cover.1782735110.git.ljs@xxxxxxxxxx
>
> --
> Cheers,
>
> David