Re: [PATCH v2] iio: adc: bcm_iproc_adc: Convert probe() to use dev_err_probe()

From: Joshua Crofts

Date: Thu Jul 30 2026 - 11:34:18 EST


On Thu, 30 Jul 2026 19:32:45 +0530
mdshahid03@xxxxxxxxx wrote:

> From: Mohammad Shahid <mdshahid03@xxxxxxxxx>
>
> Replace open-coded probe error handling with dev_err_probe() for
> resource acquisition and initialization failures.
>
> This simplifies the error paths, avoids repetitive error handling,
> and automatically suppresses duplicate messages when -EPROBE_DEFER is
> returned while preserving the existing error messages.
>
> Also remove the redundant error message after iproc_adc_enable(),
> allowing the error to be propagated without additional logging.
>
> Signed-off-by: Mohammad Shahid <mdshahid03@xxxxxxxxx>
> ---

Hi Mohammad,

Please don't reply with a new patch version to to the previous patch,
it breaks tools like b4 and appears weird in people's email clients.

Since this is just a matter of resending, please send the patch again
(not replying to the previous thread) with the tag [RESEND PATCH] in
the subject instead.

Thanks

--
Kind regards,
Joshua Crofts