Re: [PATCH RESEND] x86/fpu: Use vmemdup_user() in xstateregs_set()

From: Thorsten Blum

Date: Sun Aug 02 2026 - 08:47:44 EST


On Mon, Jul 20, 2026 at 09:55:35PM +0200, Thorsten Blum wrote:
> Replace the open-coded vmalloc() and copy_from_user() with
> vmemdup_user() to simplify xstateregs_set().
>
> vmemdup_user() returns an ERR_PTR() on failure, preserving the existing
> -ENOMEM and -EFAULT error codes. Since vmemdup_user() is backed by
> kvmalloc(), use kvfree() to free the buffer instead.
>
> Return early on error and drop the obsolete out label.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxx>
> ---
> arch/x86/kernel/fpu/regset.c | 17 ++++++-----------
> 1 file changed, 6 insertions(+), 11 deletions(-)
>
> diff --git a/arch/x86/kernel/fpu/regset.c b/arch/x86/kernel/fpu/regset.c
> index 0986c2200adc..8dc9de732c78 100644
> --- a/arch/x86/kernel/fpu/regset.c
> +++ b/arch/x86/kernel/fpu/regset.c
> @@ -3,7 +3,8 @@
> * FPU register's regset abstraction, for ptrace, core dumps, etc.
> */
> #include <linux/sched/task_stack.h>
> -#include <linux/vmalloc.h>
> +#include <linux/slab.h>
> +#include <linux/string.h>
>
> #include <asm/fpu/api.h>
> #include <asm/fpu/signal.h>
> @@ -157,21 +158,15 @@ int xstateregs_set(struct task_struct *target, const struct user_regset *regset,
> return -EFAULT;
>
> if (!kbuf) {
> - tmpbuf = vmalloc(count);
> - if (!tmpbuf)
> - return -ENOMEM;
> -
> - if (copy_from_user(tmpbuf, ubuf, count)) {
> - ret = -EFAULT;
> - goto out;
> - }
> + tmpbuf = vmemdup_user(ubuf, count);
> + if (IS_ERR(tmpbuf))
> + return PTR_ERR(tmpbuf);
> }
>
> fpu_force_restore(fpu);
> ret = copy_uabi_from_kernel_to_xstate(fpu->fpstate, kbuf ?: tmpbuf, &target->thread.pkru);
>
> -out:
> - vfree(tmpbuf);
> + kvfree(tmpbuf);
> return ret;
> }
>

I've resent this cleanup a few times and haven't received feedback. Is
this still something you would consider, or would you prefer that I drop
it? It's intended to be a mechanical cleanup with no functional changes.

Happy to rerun the relevant x86 XSAVE selftests if it helps.

Thanks,
Thorsten