Re: [PATCH 1/2] x86/cpu/hygon: Introduce macros for hygon family numbers
From: Ingo Molnar
Date: Mon Aug 03 2026 - 02:36:18 EST
* Chaohong Guo <guochaohong@xxxxxxxxxxxxxx> wrote:
> Consolidate all magic numbers of hygon CPUs into a header file,
> The macros describe the family/model numbers of hygon CPUs.
> +#define HFM(_family, _model) VFM_MAKE(X86_VENDOR_HYGON, _family, _model)
> +
> +#define HYGON_F18_M04 HFM(0x18, 4)
> +#define HYGON_F18_M06 HFM(0x18, 6)
> +#define HYGON_F18_M07 HFM(0x18, 7)
> +
> +
> +#define HYGON_7447V HYGON_F18_M07
So this is a bit misleading, AFAICT "7447V" is the enterprise server
CPU variant - but there's a bunch of smaller server and desktop
CPU variants as well that are named differently:
Model Name Core / Thread Count Base Clock Target Segment
---------- ---------------------- ---------- -------------
7447V 96 Cores / 192 Threads ~2.6 GHz Enterprise / Cloud Server
7490H 96 Cores / 192 Threads — High-Density Server
7490 64 Cores / 128 Threads 2.7 GHz Enterprise Server
7470 48 Cores / 96 Threads — Enterprise Server
3490 16 Cores / 32 Threads 2.8 GHz Desktop / Workstation
3450E 8 Cores / 16 Threads 3.6 GHz Workstation / Desktop
3450G 8 Cores / 16 Threads 2.7 GHz Workstation / Desktop
Assuming that this patch does the right thing for all
these smaller variants as well (does it?), shouldn't
the name be something like HYGON_4G or so, given
that the patch applies to the 4th generation Hygon
microarchitecture, not a specific server CPU configuration
such as 7447V?
Thanks,
Ingo