Re: [PATCH v5 13/31] KVM: s390: Prepare moving KVM/s390 to arch/s390/kvm/s390
From: Christian Borntraeger
Date: Mon Aug 03 2026 - 04:15:12 EST
Am 31.07.26 um 15:08 schrieb Steffen Eiden:
Lay the groundwork for moving the native KVM/s390 to s390/kvm/s390 to
allow for a second KVM module. Move all the kvm_host definitions to
_s390 postfixed headers. Prepare local header include guards for a new
location. Move gamp related tracing into a separate file. While at it,
rename the main KVM/s390 files from s390-kvm.{c,h} to just s390.{c,h} to
match the naming scheme of other architectures. Cleanup the KVM/s390
makefile.
No functional change.
Would it be possible to split every single semantic change into one a separate patch?
1. kvm-s390.[ch] -> s390.[ch]
2. kvm_host definitions
maybe also
3. gmap-trace change
That would make the patch easier to consume.
We can also handle that in a separate patch series (with the other s390only changes).